Geeks With Blogs

News
Welcome to my blog.
Here's what we've got on the menu today:

Lorin Thwaits A geek says what?

In my last post I talked about a great little UMPC I bought while on vacation in Japan, Sony's VGN-UX50.  Once back in the states and having caught up with work again I installed XP Pro English with SP2 in a new folder, keeping the ability to dual boot back to Japanese XP Home.  I was pleasantly surprised to find most of the drivers available right there on the hard drive.  But when installing the driver for the sound card, I got the message “Microsoft Bus Driver should be loaded in your system before installing Realtek HD Audio Driver".  This unit uses the RealTek High Definition audio chipset, and when searching on the 'net there's lots of folks with newer motherboards and RealTek audio that are having the same issue.  Q835221 gives the resolution: a QFE download (Quick Fix Escalation).  But that is only officially available by talking to Microsoft tech support.  Fortunately it can also be found bundled along with other driver downloads!  I pulled this copy out of an Intel audio driver:

KB835221.exe (QFE to fix the "Microsoft Bus" error message)

Some folks have reported mixed results after installation, so use at your own risk.  But it solved my problem 100% with no side effects.  The KB article makes it sound like it's an issue limited to XP SP1 and older, or Win2K3 RTM.  But the required UAA drivers are not included with XP SP2 or Win2K3 SP1, so it is a useful QFE to have around if you want to use newer sound cards.  One guy mentioned that even Vista Beta 2 requires it for his RealTek sound card.

UPDATE: John from the fair city of Edinburgh, Scotland had commented below that Q835221 didn't help.  For most folks with RealTek issues it works great.  But if that doesn't help then you can also try the updated driver from Q888111, which has four versions depending on your OS and SP level.

Download Q888111 for:

For those still plagued with sound issues, I hope that this updated driver helps.  On my little Sony laptop this updated driver doesn't work at all, and only the older Q835221 driver listed above was useful.

UPDATE 2: For those with Windows XP 64-bit edition or Windows Server 2003, "Tep" from Japan had written in and mentioned Q901105 which offers an updated version of the hdaudbus.sys driver.  As a side-note, this is certanly a popular topic, getting 90,000 hits since I had first posted it.  Thanks go out to those who have written in to help us know what works and what doesn't.

Posted on Sunday, June 11, 2006 11:40 PM Errors | Back to top


Comments on this post: Fixing the "Microsoft Bus Driver" error message when installing a RealTek sound card

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Lorin Thwaits | Powered by: GeeksWithBlogs.net