Geeks With Blogs

News
Charles Young

The project I am currently working on ran into a problem with a custom XSLT attached to a BizTalk map.   The XSLT transforms a simple BizTalk message into an XHTML page.  One of the fields in the BizTalk message carries an XHTML payload that needs to be 'dumped' verbatim into the page produced by the transform.   To do this, we use the <value-of> element with the disable-output-escaping attribute set to 'yes'.  This prevents the XSLT engine from outputting entities such as &lt; and &gt; instead of < and >.

 

We tested the XSLT using the .NET framework, the MSXML XSLT engine and the default XSLT engine included in XML Spy.   Everything worked fine.   However, when we attached the XSLT to a BizTalk map and deployed our solution, the output escaping was not disabled on some dev machines, but was on others!   When we tested the map in Visual Studio, everything worked fine.

 

The reason?   Well, SP1 shipped after the project started, and we had not managed to deploy the service pack onto all the dev machines (oops).   A look at the newsgroups revealed that this problem has been experienced by others.  SP1 fixes it, though the fix does not appear to be documented at http://support.microsoft.com/default.aspx?scid=KB;EN-US;888740.   The problem is rather similar, however, to the issue described in 841563.

 

There is much more good stuff in SP1 than Microsoft let on.  Install BizTalk SP1 now!

Posted on Thursday, March 3, 2005 12:55 PM BizTalk Server 2004/2006 | Back to top


Comments on this post: BizTalk Server 2004: Install BizTalk SP1 now!

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Charles Young | Powered by: GeeksWithBlogs.net