Geeks With Blogs

News

2004-2009
Celebrate Computer Science Education
Locations of visitors to this page
Brian Scarbeau Insights from a seasoned Computer Science Trainer

Today I had some time to install the latest version of dotnetnuke which uses ASP.NET 2.0. The installation was on a local pc and I must say it really was a breeze to install. I used the new starter kit that comes with this version and with instructions from Shawn Walker who is the leader of this open source project.

Using Visual Web Developer  is another plus especially for teachers who want to teach their students about web portals. You don't need to install IIs on each pc in the computer lab because Visual Web Developer has it's own web server that is similiar to the one used by Webmatrix.

There are many similiarties to this version and version 3. All of the core modules are the same and the survey and usersonline modules are installed automatically. Not like version 3 where you had to add these modules via Host, Module Definition. 

There are two new admin menu items. One is for Languages and the other is Authentication. There's a list of different languages that you can use with dotnetnuke. This would be great for customers who need this added feature. The authentication is to customise for your windows authentication.

The Host Settings remain the same as version 3. The look and feel of this new version is the same as 3.

One thing I did notice on the dotnetnuke download page was a seperate download for the documentation.  There are 20 pdf files full of information about dotnetnuke. From skinning, module development, installation guide, localization, membership, module definition and much more.

I'm in the process of reading these and learning more. All of the core modules worked fine on the newly created pages that I created and I'm in the process now of installing some modules that I have with version 3. I'm learning that some work with version 4 and some don't. The most common error that I'm getting is this:

A critical error has occurred.
MinMax persistance type of cookie requires a ModuleId

I'm in the process now to investigate why I'm getting this error.

All in all, I highly recommend high school teachers to take a look at dotnetnuke.

Posted on Thursday, January 26, 2006 12:53 PM Teaching with ASP.NET , DotNetNuke | Back to top

Copyright © Brian Scarbeau | Powered by: GeeksWithBlogs.net